ActiveRubyのrake

たまには、Rubyのバージョンをアップさせようと、ActiveRubyを再インストールとりあえず1.8.7。RGSSが1.8系なので、同じ系統にしてるけど、いつまでもつのかな~?と…

で、入れたけど、rakeが動かなかった。

ruby.exe: No such file or directory -- C:/Program Files/ruby-1.8/bin/rake (LoadError)

とか言われる。
う~ん。たしかに、そんなファイル無いけど…rake.rb を読みたいんじゃないかね?
ってことで、bin/rake.rbを bin/rakeにコピー。

ふむ、とりあえず動くぽい。なんだろう?(特に検索してないけど…まいっか。うごいてるぽいから)

今は、テンプレートプロジェクトを作るために、ゲーム内のデータベースを修正する必要があって
とても大変だから、LibreOffice のスプレッドシートからxmlを吐かせて、そこから rxdata を作る様なコンパイラを作成中。
RPGツクールXPの基本的なデータは作れるようになった。アクターとかエネミー、システム情報とかアイテム、武器、防具、スキル等々…とりあえずね。
編集しやすいかどうかはあるけど、スプレッドシートで全体をみつつ簡単に編集できるので楽だ。
rakeで使えるようになる予定…

これ進めていくと、ツクールいらなくなるかもね~?

カテゴリー: 未分類 タグ: パーマリンク

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です